Les Trucs & Astuces Informatiques de Michel

http://michel.vergriete.perso.sfr.fr/accueil.htm
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 [résolu]remplir automatiquement région à partir des CP

Aller en bas 
AuteurMessage
deusirae



Nombre de messages : 4
Date d'inscription : 19/01/2007

MessageSujet: [résolu]remplir automatiquement région à partir des CP   Ven 19 Jan - 5:46

Bonjour,

Je suis à la recherche d'une macro ou d'un système me permettant de remplir automatiquement une colonne "région" à partir de la colonne code postal de mon fichier.

Pour vous donner une idée de mon niveau, je ne vois que la fonction SI pour faire ca, mais 96 si imbriqués, ca va faire vomir mon fichier je pense.

J'ai déjà la liste des région par rapport à leur N° de dept, je sais extraire le N° dept du CP (ca va ca, c'est pas trop dur).

Vous avez des idées sur comment je pourrais faire ca ?

Merci d'avance.


Dernière édition par le Lun 22 Jan - 3:25, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
eric



Nombre de messages : 154
Date d'inscription : 17/07/2006

MessageSujet: Re: [résolu]remplir automatiquement région à partir des CP   Sam 20 Jan - 10:55

bonjour
il semble que la fonction INDEX() est adaptée sous ce genre de problème
http://bvrve.club.fr/Astuces_Michel/246excel.php
sinon joindre le fjchier
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
deusirae



Nombre de messages : 4
Date d'inscription : 19/01/2007

MessageSujet: Re: [résolu]remplir automatiquement région à partir des CP   Lun 22 Jan - 1:18

La fonction INDEX sert apparemment pour faire des listes déroulantes, ce qui ne correspond pas à ce que je cherche en fait.

Je ne peux joindre mon fichier (plein de données nominatives dedans), mais je peux vous en donner la structure, c'est tout simple :

Raison sociale | civilité | nom | prénom | fonction | adresse | BP | code postal | ville | région | Date de contact | résultat contact | (...)

Toutes les zones sont saisies à la main à partir de fichiers prospects qualifiés.

Ce que je cherche à faire, c'est automatiser la saisie de la région par rapport aux 2 premiers chiffres du CP.

PAr la fonction SI, cela donne par exemple : SI (GAUGHE(G2,2)=75;"ile de France;(SI(GAUCHE(G2,2)=33;"gironde";SI...

Avec 96 SI enchainés.

Ce que je voudrais, par rapport à une table des régions, c'est faire un truc qui donnerait : si GAUCHE(G2,2) est dans la cellule A17 d'un autre tableau (que celui-ci soit un vrai tableau ou des valeurs saisies dans une macro), alors I2=valeur dans la cellule B17 de cet autre tableau.

En espérant avoir été plus clair, merci.
J'ai trouvé en grosse partie avec ceci :
=SI(N2="";"Pas de CP";RECHERCHEV(ENT(N2/1000);Feuil2!A2:B96;2;0))

Reste un problème : quand je recopie la formule vers le bas, Excel m'augmente les valeurs des références dans les autres tables.

Donc =SI(N2="";"Pas de CP";RECHERCHEV(ENT(N2/1000);Feuil2!A2:B96;2;0)) à la ligne 2 devient
=SI(N25="";"Pas de CP";RECHERCHEV(ENT(N25/1000);Feuil2!A25:B119;2;0)) à la ligne 25...

C'EST BON, j'ai tout !!!!

Merci à ceux qui auront réfléchi au problème.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: [résolu]remplir automatiquement région à partir des CP   

Revenir en haut Aller en bas
 
[résolu]remplir automatiquement région à partir des CP
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [résolu]pc infecté par wwwzuc32.exe
» [ résolu ]à propos de TFC
» Optimisation sécurité PC [Résolu]
» [Résolu] Fenêtres publicitaires intempestives
» [résolu]EXCEL

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Les Trucs & Astuces Informatiques de Michel :: Bureautique-
Sauter vers: